Card transactions may be declined
Incident Report for Starling Bank
Resolved
The issue has been resolved and all services are operating as normal. We are very sorry for the inconvenience.
Posted 4 months ago. Jul 26, 2017 - 11:36 UTC
Investigating
We are currently experiencing issues with our cards – your card transactions may be declined and you won’t be able to access your card details in the app at the moment. We are investigating the issue, but we would encourage you use or carry alternative cards at this time.
Posted 4 months ago. Jul 26, 2017 - 11:09 UTC