Cards may currently be declined
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 25, 2017 - 11:43 UTC
Investigating
We are currently experiencing an issue with card processing and so your card may be declined. We expect less than 20% of transactions to be affected. We are investigating.
Posted about 1 month ago. Oct 25, 2017 - 11:24 UTC