In-app chat unavailable
Incident Report for Starling Bank
Resolved
In-app chat issues are now resolved. We're sorry for the inconvenience.
Posted about 1 month ago. Jul 12, 2017 - 18:09 UTC
Monitoring
We are sorry, in-app live chat is currently unavailable. If you need help, you can still message or call us from the app! We are working hard to resolve the problem.
Posted about 1 month ago. Jul 12, 2017 - 14:24 UTC