Card declines
Incident Report for Starling Bank
Resolved
We are now processing normally again. We are really sorry for any inconvenience caused and are working hard with our supplier to try and prevent such issues in future.
Posted about 1 month ago. Nov 03, 2017 - 17:38 UTC
Investigating
We’re sorry. Some card transactions may be delayed or declined, and cash withdrawals will be unavailable.
We’re working to minimise the impact to you. We are sorry for any inconvenience caused.
Posted about 1 month ago. Nov 03, 2017 - 15:23 UTC