Planned Maintenance
Incident Report for Starling Bank
Resolved
Planned maintenance is now complete. We expect all card operations to work as normal. Sorry for any inconvenience.
Posted about 2 months ago. Oct 08, 2017 - 01:14 UTC
Monitoring
Planned maintenance tonight from midnight until 2am, Sunday 8th October. Your card may be declined during this period, so we advise you to withdraw cash as a back-up.
Posted about 2 months ago. Oct 07, 2017 - 09:13 UTC