Card declines
Incident Report for Starling Bank
Resolved
Card processing is back to normal.
Posted about 1 month ago. Nov 03, 2017 - 09:58 UTC
Investigating
We're sorry. We’re experiencing some issues and cards may be declined at the moment.
We’re working to minimise the impact to you, we expect only some card transactions to be delayed or declined and cash withdrawals will be unavailable.
Posted about 1 month ago. Nov 03, 2017 - 09:49 UTC