Apple Pay Degraded Performance
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 06, 2019 - 15:41 UTC
Identified
We're aware that a small number of customers have experienced problems making payments via Apple Pay this morning. If you're affected, please simply delete your card from Apple Pay and add it again. We apologise for the inconvenience. We're working to resolve this as soon as possible
Posted 9 months ago. Feb 06, 2019 - 09:16 UTC
This incident affected: Mobile Wallets (Apple, Google, Samsung & Garmin Pay).