Card services disruption
Incident Report for Starling Bank
Resolved
Some customers may have experienced issues with their card transactions, ATM withdrawals and card information in app. The service has now been restored and card transactions are processing normally. We are monitoring the situation closely.
Posted Sep 09, 2020 - 23:45 UTC
Investigating
Some customers may experience issues with their card transactions, ATM withdrawals and card information in app. We are investigating and are looking to resolve as soon as possible. We are sorry for any inconvenience.
Posted Sep 09, 2020 - 23:37 UTC
This incident affected: Debit Cards.