Service Disruption to Post Office Transactions
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted Dec 10, 2019 - 15:48 UTC
Investigating
Customers may currently experience problems depositing and withdrawing from the Post Office. We are working to resolve this as quickly as possible.
Posted Dec 10, 2019 - 15:37 UTC
This incident affected: Post Office Deposits / Withdrawals.