Some card payments might fail
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 12, 2018 - 18:55 UTC
Update
We are continuing to monitor for any further issues.
Posted 4 months ago. Jul 12, 2018 - 18:54 UTC
Monitoring
Earlier this evening Mastercard experienced a global issue. Card payments now appear to be working normally. We continue to monitor closely. Sorry if your evening has been disrupted.
Posted 4 months ago. Jul 12, 2018 - 18:40 UTC
Identified
MasterCard are experiencing a global issue with their systems this evening and your card may be declined.

If this happens, please try again. You may also receive a notification saying your transaction was reversed. The purchase will still complete successfully and the retailer will be paid.

We apologise for the inconvenience and will update as soon as we hear more.
Posted 4 months ago. Jul 12, 2018 - 17:47 UTC
Investigating
We are getting reports of issues using MasterCards this evening. This appears to be affecting multiple banks. We are in contact with MasterCard for further information. Some transactions are going through so please try again. We apologise for the inconvenience caused.
Posted 4 months ago. Jul 12, 2018 - 17:29 UTC
This incident affected: Debit Cards.