Service Disruption
Incident Report for Starling Bank
Resolved
This incident is now resolved. We’re sorry for any inconvenience caused.
Posted Feb 08, 2021 - 13:02 UTC
Monitoring
Some customers may have experienced issues trying to call us this morning (08/02/21). The service has now been restored. We are monitoring the situation closely.
Posted Feb 08, 2021 - 11:11 UTC
Investigating
We are currently experiencing some issues with customers trying to call us. Our team can still help you if you’d like to contact us by in-app chat. Go to Help in the app and select contact us; and chat. Our team are working to resolve this asap and we’re sorry for any inconvenience.
Posted Feb 08, 2021 - 09:37 UTC
This incident affected: Customer Support.