Inbound Calls Not Connecting
Incident Report for Starling Bank
Resolved
Calls to our customer service centre are now connecting after a brief gap. Our customer service communications are back to normal. We apologise for any inconvenience.
Posted Feb 11, 2021 - 10:11 UTC
Monitoring
Calls to our customer service centre are now connecting after a brief gap. Our customer service communications are back to normal. We apologise for any inconvenience.
Posted Feb 11, 2021 - 10:02 UTC
Investigating
Calls to our customer service centre are currently not connecting. If you need help, please contact us via in-app chat, message or email. We apologise for any inconvenience.
Posted Feb 11, 2021 - 09:51 UTC
This incident affected: Customer Support.