Intermittent Faster Payments
Incident Report for Starling Bank
Resolved
We experienced some intermittent delays on faster payments which have now been resolved. We apologise for any inconvenience caused.
Posted 4 months ago. Apr 06, 2019 - 18:00 UTC
Investigating
We are experiencing intermittent issues with Faster Payments in and out of accounts. We are working to resolve this issue
Posted 4 months ago. Apr 06, 2019 - 17:13 UTC
This incident affected: Faster Payments.