Issues receiving calls
Incident Report for Starling Bank
Resolved
Earlier issues with phone calls to our customer service team have been resolved. We are sorry for the inconvenience.
Posted Sep 09, 2020 - 14:10 UTC
Update
We are continuing to investigate this issue.
Posted Sep 09, 2020 - 12:06 UTC
Investigating
We are currently experiencing issues receiving calls. We’re sorry for any inconvenience. We are working to fix this as soon as possible. If you can’t get through to us, you can try chat or send us an in-app message and we will be able to get back to you. To access an in-app message from your app, select the Get in Touch option, select send us a message and we will get back to you as soon as possible.
Posted Sep 09, 2020 - 12:01 UTC
This incident affected: Customer Support.