Phone Calls to Customer Service
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 15:27 UTC
Monitoring
Earlier issues with phone calls to our customer service team have been resolved. The phone lines are now back up. We are sorry for the inconvenience.
Posted Jun 03, 2020 - 13:09 UTC
Investigating
Some customers are having difficulty getting through to our customer service team by phone. We are investigating and are looking to resolve as soon as possible. We will keep you updated. We are sorry for the inconvenience. You can still contact our customer services team through in-app chat.
Posted Jun 03, 2020 - 12:36 UTC
This incident affected: Customer Support.