Bank payments may be delayed
Incident Report for Starling Bank
Resolved
Bank payments are now processing as normal.
Posted 4 months ago. Jul 08, 2018 - 17:20 UTC
Identified
Bank payments may be delayed by an issue impacting several banks. The Faster Payments Scheme are investigating.
Posted 4 months ago. Jul 08, 2018 - 14:55 UTC
This incident affected: Faster Payments.