Service Disruption to Card Transactions
Incident Report for Starling Bank
Resolved
Your card should now be working as expected. Once again we apologise for any inconvenience caused. Should you have any discrepancies on your account transactions, this will be rectified within the next few days.
Posted about 1 month ago. Sep 13, 2019 - 13:08 UTC
Monitoring
We are continuing to monitor the situation closely, but your card should now be working as expected. Once again we apologise for any inconvenience caused. Should you have any discrepancies on your account transactions, this will be rectified within the next few days.
Posted about 1 month ago. Sep 13, 2019 - 12:36 UTC
Investigating
Some customers may experience issues with their card transaction. Please do re-try. You can still withdraw money from the Post Office. We are investigating and are looking to resolve as soon as possible. We are sorry for any inconvenience.
Posted about 1 month ago. Sep 13, 2019 - 11:51 UTC
This incident affected: Debit Cards.