Issues with card and wallet transactions
Incident Report for Starling Bank
Resolved
A temporary issue with card and wallet transactions has been resolved.
Posted 3 months ago. Jul 26, 2019 - 13:03 UTC
Investigating
We are currently experiencing intermittent issues with card and wallet transactions, which may be declined. We’re working to fix this as soon as possible. We’re sorry for any inconvenience. If you’re having issues with ATM cash withdrawals you can withdraw cash at the Post Office instead.
Posted 3 months ago. Jul 26, 2019 - 12:29 UTC
This incident affected: Debit Cards.