Card Payments Declined
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 17, 2018 - 14:27 UTC
Investigating
We're sorry we had an issue with some of our cards and a few transactions were declined. We are now processing normally again. Please contact us if you experience any problems.
Posted 3 months ago. Aug 17, 2018 - 13:47 UTC
This incident affected: Debit Cards.