Intermittent issues using MasterCard abroad
Incident Report for Starling Bank
Resolved
We have been advised that all transactions should be processing normally again. Thank you for your patience.
Posted about 1 month ago. Jun 12, 2018 - 10:12 UTC
Investigating
MasterCard are currently experiencing issues in their network in some parts of the world and transactions may be declined. We believe all UK transactions are processing normally and are in communication with MasterCard who are working to resolve the issue. We are sorry for any inconvenience caused and will keep you updated as we hear more.
Posted about 1 month ago. Jun 12, 2018 - 08:42 UTC
This incident affected: Debit Cards.