Card Payments
Incident Report for Starling Bank
Resolved
This incident has now been resolved.
Posted Feb 07, 2022 - 18:24 GMT
Investigating
We’re aware that some customers may be experiencing problems when trying to complete some card transactions. Our team are aware of the issue and working to fix this as soon as possible. We’re sorry for any inconvenience.
Posted Feb 07, 2022 - 17:01 GMT
This incident affected: Debit Cards.