Service Disruption
Incident Report for Starling Bank
Resolved
This incident has been resolved. We’re sorry for any inconvenience.
Posted May 06, 2021 - 15:19 UTC
Monitoring
Some customers may have experienced issues that were causing some transactions, including at the Post Office, to be declined. The service has now been restored. We are monitoring the situation closely.
Posted May 06, 2021 - 14:49 UTC
Investigating
We’re investigating an issue which is causing some transactions, including at the Post Office, to be declined. We’re sorry for any inconvenience. We’re investigating as a matter of urgency.
Posted May 06, 2021 - 12:53 UTC
This incident affected: Debit Cards and Post Office Deposits / Withdrawals.