Service Disruption
Incident Report for Starling Bank
Resolved
We were experiencing some disruption to our service earlier with some card transactions being declined. This has now been resolved. Sorry for the inconvenience.
Posted about 1 year ago. Sep 14, 2018 - 15:59 UTC
Update
We are continuing to investigate this issue.
Posted about 1 year ago. Sep 14, 2018 - 15:45 UTC
Investigating
We are currently experiencing a disruption. Some customer card transactions may be declined. We're sorry for the inconvenience. We are investigating this and will keep you updated.
Posted about 1 year ago. Sep 14, 2018 - 15:40 UTC
This incident affected: Debit Cards, New Account Opening, iOS Application, and Android Application.