Partial outage of international payments
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted Mar 31, 2021 - 16:03 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2021 - 14:41 BST
Investigating
We are aware that some customers may be experiencing problems when trying to attempt to make international payments, and receiving quotes for sending GBP to other currencies.
Our team are aware and looking into this to resolve it as soon as possible. Please do attempt to retry your payment as it may work. We’re sorry for any inconvenience.
Posted Mar 31, 2021 - 13:33 BST
This incident affected: International Payments.