Degraded Card Service
Incident Report for Starling Bank
Resolved
A temporary issue with card and wallet transactions has been resolved.
Posted about 1 month ago. Aug 15, 2019 - 08:37 UTC
Monitoring
A temporary issue with card and wallet transactions has been resolved. We will continue to monitor
Posted about 1 month ago. Aug 15, 2019 - 08:22 UTC
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Aug 15, 2019 - 08:19 UTC
Investigating
We are experiencing some issues with card transactions which may be declined. We are looking to resolve ASAP.
Posted about 1 month ago. Aug 15, 2019 - 07:42 UTC
This incident affected: Debit Cards.