Service Disruption
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 18:08 UTC
Monitoring
We are continuing to monitor the situation closely, but you should be able to use the app now. Once again we apologise for any inconvenience caused.
Posted Jan 22, 2021 - 17:45 UTC
Identified
Some customers may be experiencing issues making payments and with some app functions. We are investigating and are looking to resolve as soon as possible. We are sorry for any inconvenience.
Posted Jan 22, 2021 - 17:32 UTC
This incident affected: New Account Opening, iOS App, and Android App.