Post office Cash Services impacted

Incident Report for Starling Bank

Resolved

Thank you for your patience. This incident is resolved.
Posted Feb 25, 2026 - 18:55 GMT

Monitoring

We are currently aware of an issue affecting cash deposits, cash withdrawals and balance checks at the Post Office. We are actively monitoring the situation. We apologise for the inconvenience caused.
Posted Feb 25, 2026 - 16:00 GMT
This incident affected: Post Office Deposits/Withdrawals.