Service Disruption to Card Transactions
Incident Report for Starling Bank
Resolved
This incident has been resolved
Posted about 1 month ago. Aug 15, 2019 - 12:20 UTC
Investigating
We are currently experiencing issues with card transactions which may be declined. We are looking to resolve as soon as possible.
Posted about 1 month ago. Aug 15, 2019 - 11:56 UTC
This incident affected: Debit Cards.