Card Payments
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted May 29, 2021 - 12:27 BST
Update
We are continuing to work on a fix for this issue.
Posted May 29, 2021 - 12:26 BST
Identified
We’re investigating an issue that is causing some Mastercard transactions, including some ATM withdrawals, to be declined. We apologise for any inconvenience. Please retry with a different card if possible.
Posted May 29, 2021 - 11:41 BST
This incident affected: Debit Cards.