Duplicate Transactions
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 01, 2018 - 12:02 UTC
Update
Duplicate transactions appeared in some customer feeds yesterday after some merchants submitted the same payment twice. We were assured it would be remedied by this morning and customers who were charged twice would be refunded. This has not happened yet and we are following this up. We’re sorry about this. We will keep you updated.
Posted 3 months ago. Sep 01, 2018 - 09:54 UTC
Identified
Duplicate transactions appeared in some customer feeds today after some merchants submitted the same payment twice. The problem has been fully identified. We’re assured it will be remedied by Saturday morning and customers who were charged twice will be refunded. We’re sorry about this.
Posted 3 months ago. Aug 31, 2018 - 12:31 UTC
Update
You may see duplicated transactions on your feed. This has been caused by an error on the part of the bank used by some merchants. This will be corrected and if you’ve been charged twice you’ll be refunded. We’re sorry about this.
Posted 3 months ago. Aug 31, 2018 - 12:30 UTC
Investigating
We're getting reports of duplicated card transactions from some merchants which is affecting many banks. We're sorry about this. If you've been charged more than once this will be rectified. We'll keep you updated.
Posted 3 months ago. Aug 31, 2018 - 11:28 UTC
This incident affected: Debit Cards.