Service Disruption
Incident Report for Starling Bank
Resolved
This incident has been resolved. We’re sorry for any inconvenience.
Posted Apr 15, 2021 - 09:30 UTC
Monitoring
The service has now been restored and online card transactions are processing normally. We are monitoring the situation closely.
Posted Apr 15, 2021 - 09:02 UTC
Investigating
We’re aware that some customers may be experiencing problems when trying to complete online card transactions. Our team are aware of the issue and working to fix this as soon as possible. If the merchant has an option to pay by mobile wallet, please try this option for making your payment. We’re sorry for any inconvenience.
Posted Apr 15, 2021 - 07:28 UTC
This incident affected: Debit Cards.