Delays to International Payments
Incident Report for
Starling Bank
Resolved
This incident has been resolved.
Posted
Oct
01
,
2025
-
22:43
BST
Identified
We are currently experiencing delays of up to 36 hours processing international inbound and outbound payments. You may want to choose alternative methods if you want to make an outbound international payment at this time.
Posted
Oct
01
,
2025
-
18:05
BST
This incident affected: International Payments.
×
Subscribe to Incident
Subscribe to updates for
Delays to International Payments
via . You'll receive .