Card services disruption
Incident Report for Starling Bank
Resolved
We had some card issues earlier. Card services are now working as expected. Post Office withdrawals and deposits are now restored. We're sorry for any inconvenience caused. Should you have any discrepancies on your account transactions, this will be rectified within the next few days
Posted Jan 14, 2020 - 15:20 UTC
Investigating
Some customers may experience issues with their card transactions and ATM withdrawals. Post Office withdrawals and deposits are currently unavailable. We are investigating and are looking to resolve as soon as possible. We are sorry for any inconvenience. Your transaction feed will self correct in the coming days.
Posted Jan 14, 2020 - 15:01 UTC
This incident affected: Debit Cards and Post Office Deposits / Withdrawals.