Intermittent issues obtaining international payment quotes
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 01, 2018 - 14:05 UTC
Investigating
Some customers are experiencing issues obtaining quotes for international transfers. We're actively investigating this issue, thanks for your patience whilst we try to resolve the problem.
Posted 5 months ago. Jun 01, 2018 - 11:00 UTC
This incident affected: International Transfers.