Some online transactions declining

Incident Report for Starling Bank

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 10:02 BST

Update

We are continuing to investigate this issue.
Posted Jul 15, 2026 - 09:44 BST

Investigating

We are aware of an issue with some online transactions declining. We are currently investigating this and apologise for any inconvenience.
Posted Jul 15, 2026 - 09:42 BST
This incident affected: Debit Cards.