Intermittent Problems with Customer Support Calls
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted 11 days ago. Nov 05, 2018 - 18:01 UTC
Monitoring
Our telephony problems appear to have been resolved. We will continue to monitor this.
Posted 11 days ago. Nov 05, 2018 - 17:49 UTC
Investigating
We are experiencing some intermittent problems with our telephony which means that calls to Customer Services may fail. Please reach out to us in-app if you need to contact us.
Posted 11 days ago. Nov 05, 2018 - 17:37 UTC
This incident affected: Customer Support.