Some Online Transactions Failing
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 17:37 BST
Investigating
We are aware that MasterCard are experiencing an issue which means that some online card transactions are currently failing. We are aware and are working with MasterCard to resolve this. We apologise for the inconvenience caused.
Posted Jun 12, 2023 - 15:14 BST
This incident affected: Debit Cards.