Service Disruption
Incident Report for Starling Bank
Resolved
This incident has been resolved. We’re sorry for any inconvenience.
Posted May 04, 2021 - 20:03 UTC
Identified
We are aware that some customers may be experiencing problems when trying to phone our customer service team from within the app. Our in app chat is open and fully operational. Please call us on 0207 9304 450 if you need to speak to someone urgently.
Our team are aware and looking into this to resolve it as soon as possible. We’re sorry for any inconvenience.
Posted May 04, 2021 - 14:01 UTC
This incident affected: Customer Support.