Service Disruption
Incident Report for Starling Bank
Resolved
Following a short disruption to Post Office services earlier today, we can confirm that all services, including depositing and withdrawing money, are now operational. We are sorry for any inconvenience during the disruption.
Posted Mar 03, 2021 - 13:33 UTC
Investigating
We are aware that customers are unable to access services in the Post Office, including depositing or withdrawing money. Our team is working to fix this as soon as possible. We are sorry for any inconvenience.
Posted Mar 03, 2021 - 13:04 UTC
This incident affected: Post Office Deposits / Withdrawals.