Card Payments
Incident Report for Starling Bank
Resolved
This incident has been resolved.
Posted Apr 03, 2023 - 11:07 BST
Monitoring
We had some card issues earlier. Your card should now be working as expected. We're very sorry for any inconvenience caused.
Posted Apr 03, 2023 - 09:53 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 03, 2023 - 09:49 BST
Investigating
Some customers may experience issues with card transactions and ATM withdrawals. We are investigating and will resolve this as soon as possible. We are sorry for any inconvenience.
Posted Apr 03, 2023 - 09:03 BST
This incident affected: Debit Cards.