Service Disruption to Card Transactions
Incident Report for Starling Bank
Resolved
We’re sorry our card payments were down earlier on 9 September. Most transactions were processed successfully, but there may be a delay in some of these appearing on your feed.
Posted 11 days ago. Sep 09, 2019 - 15:35 UTC
Monitoring
Earlier today some customers may have experienced issues with card transactions. The situation is now stable however we continue to monitor closely.
Posted 12 days ago. Sep 09, 2019 - 14:43 UTC
Identified
We are still experiencing issues with some card transactions. We are investigating and are looking to resolve as soon as possible. We are sorry for any inconvenience.
Posted 12 days ago. Sep 09, 2019 - 13:43 UTC
Monitoring
Some customers may have experienced issues with card transactions earlier today. We are now seeing more stability. We will continue to monitor the situation.
Posted 12 days ago. Sep 09, 2019 - 13:38 UTC
Identified
We are currently experiencing issues with some card transactions. You can still withdraw cash at the Post Office. We are investigating and are looking to resolve as soon as possible. We are sorry for any inconvenience.
Posted 12 days ago. Sep 09, 2019 - 11:52 UTC
This incident affected: Debit Cards and Post Office Deposits / Withdrawals.