Service Disruption
Incident Report for Starling Bank
Resolved
This incident is now resolved. We're sorry for any inconvenience caused.
Posted Jan 30, 2021 - 19:59 UTC
Monitoring
Some customers may have experienced issues with online card purchases and in-app card services.
The service has now been restored. We are monitoring the situation closely.
Posted Jan 30, 2021 - 19:33 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 30, 2021 - 18:30 UTC
Identified
We are aware some customers may be experiencing issues with online card purchases and in-app card services (such as seeing card details in app, and activating cards). We are investigating and are looking to resolve as soon as possible. We are sorry for any inconvenience.
Posted Jan 30, 2021 - 18:00 UTC
This incident affected: Debit Cards and Post Office Deposits / Withdrawals.